Jump to content
Unfortunately we had to take download section back offline temporarily. We should have it working normally soon.

HyperSync still won´t run (after 3 years...)


Recommended Posts

Hi there,

I am having this Critical Error when I try to run HyperSync.

It is the first time I am trying to run it on this machine. I have win 10 with the latest .NET Framework 4.8 installed.

System.Runtime.InteropServices.COMException (0x80040154): Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))
   at System.Windows.Forms.UnsafeNativeMethods.CoCreateInstance(Guid& clsid, Object punkOuter, Int32 context, Guid& iid)
   at System.Windows.Forms.AxHost.CreateWithoutLicense(Guid clsid)
   at System.Windows.Forms.AxHost.CreateWithLicense(String license, Guid clsid)
   at System.Windows.Forms.AxHost.CreateInstanceCore(Guid clsid)
   at System.Windows.Forms.AxHost.CreateInstance()
   at System.Windows.Forms.AxHost.GetOcxCreate()
   at System.Windows.Forms.AxHost.TransitionUpTo(Int32 state)
   at System.Windows.Forms.AxHost.CreateHandle()
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.AxHost.EndInit()
   at HyperSync.Forms.Secondary.Subscribe.InitializeComponent()
   at HyperSync.Forms.Secondary.Subscribe..ctor()
   at HyperSync.Forms.Primary.MainWindow..ctor()
   at HyperSync.Program.Main()


I already had a similar problem more than 3 years ago and today I decided to run HyperSync on another machine, all new parts, in another part of the country... and the same thing persists. I see that my previous post went unresolved for many users that had the same issue. 

I wonder if now there´s an update or more knowledge to address this problem.

Thank you for your support.

Link to comment
Share on other sites

Hi there, 

I just installed all the x64 2010, 2012, 2013 and 2015, 2017, 2015-2019 C++ redistributables and the problem persists in my WIN 10 machine.

I did notice that the following line disappeared from the debug.log file though:

at System.Windows.Forms.AxHost.CreateWithoutLicense(Guid clsid)


I wonder if there is a way to find out and localize the missing DLL or COM file.

Any other ideas? Thank you.



Link to comment
Share on other sites

When I look at my installs it seems I have both the x86 and x64 of all redistributables. Not sure if that matters, just pointing it out:


Also HS itself needs sxs.dll to run under windows 10:

...so maybe hypersync needs this file too??? Unsure because I am still win7 here. Other than that I am not sure what to say.

Link to comment
Share on other sites

I really appreciate your time and all the answers and guidance you have been giving me.

I tried replacing the sxs.dll file in the HS folder, and installed the x86 2010, 2012, 2013 and 2015, 2017, 2015-2019 C++ redistributables and the x86 and x64 versions of Windows Desktop Runtime, and unfortunately the issue is still there. 

The debug log is pretty much the same (attached here). I suppose my last resort would be to try every step of what this user mentions, and see if I manage to nail it:

Thank you. If one day there's a workaround to about this issue, I would much appreciate a direct message to let me know. Now, I have two machines that won't run Hypersync...


Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...

I have this issue as well.  It doesn't work on two of my computers - works fine on the third.  

I mirrored all .net and Visual c++ installations but still no luck.  No idea what this could be.  I'm not sure why whomever made this program can't just say what is required to run it after all of these years.  Definite PITA.  

Link to comment
Share on other sites

  • 5 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...