Jump to content
Clivvy

Controls not working correctly

Recommended Posts

HI guys,

 

hope you can help.

 

Today I updated my setup to RocketLauncher, this went well. On first launch, Hyperspin wouldn't work with my Xbox One controller, where it did previously. I fiddled about a bit then it started to work. I still had the issue with the analogue stick where it would scroll the wheels really fast left or right. I tried to resolve this via HyperHQ, but somewhere along the way my controls don't work at all now in the Main Menu. So I launch Hyperspin, and the xbox one controller doesn't work (though the start button does?!) and I cant exit out of the main menu via the ESC key.

 

If I hit the start button on the controller, or enter on the keyboard, I advance to the console menu as you would expect, and I can then scroll through the games via the controller and keyboard, and ESC back, though when scrolling it skips through several games rather than stepping one at a time.

 

Ive had a search, and I just cant find a solution. And even worse, I deleted my backup. Rather than go undeleting id like to understand what has gone wrong, and how I can fix it.

 

can anyone help? How do I get the controls working again in the main menu??

Share this post


Link to post
Share on other sites

From what I understand (and I might be wrong) is that analog/joystick controls don't work well in the Hyperspin 1.3 menus. This is fixed in the upcoming 1.4 (which is being tested right now).

There is a script people talk about called Gutches script (I think) that might be able to fix this for you. Not sure if it is found here in the download section or not though.

Share this post


Link to post
Share on other sites

oops, I apologise, I am running 1.4!

 

It worked with the EXC key first few times, but no longer :(

 

I will check the discussion though, thanks for the link!

Share this post


Link to post
Share on other sites

looks like I've already read this, and I have tried the script before. What I have found though, is that when in the console menu, scrolling around the games works perfect - no more skipping when using the controller. I just cant do anything inside the main menu other than hit enter to go into a console, or the left/right arrow for consoles. I cant exit back to windows...!

Share this post


Link to post
Share on other sites

ok, bit more info. I retraced my steps, and I had renamed all the "Other " folders in Media to Other.old - I didn't want the pointers to show in any wheel or menu. This worked, but stopped key presses from working. I renamed the other folder back in Mani Menu, and now the joystick works ok (apart from skipping a bunch of consoles press).

 

Despite this, the keyboard doesn't work at all....

Share this post


Link to post
Share on other sites

bit more info - sorted the scrolling speed of the console selection in the main menu, that was down to a setting in the main menu ini file set to high (changed it to low)

 

the ESC key still dosnt work in the Main Menu, so I cant exit out of Hyperspin normally, I'm having to Task Manager it

Share this post


Link to post
Share on other sites

ok I sussed it. It was the Settings.ini.

 

Exit_Default=yes

 

but

 

Enable_Exit=false.

 

changed false to true.

 

this change occurred during the transition, no idea at all if it will affect anyone else but ive tried to give you guys helpful feedback.

 

cheers.

  • Upvote 1

Share this post


Link to post
Share on other sites

Good to know. Glad you sorted it out.

Note to self "when all else fails, check the ini files"

  • Upvote 1

Share this post


Link to post
Share on other sites

looks like I've already read this, and I have tried the script before. What I have found though, is that when in the console menu, scrolling around the games works perfect - no more skipping when using the controller. I just cant do anything inside the main menu other than hit enter to go into a console, or the left/right arrow for consoles. I cant exit back to windows...!

 

Have same issue. Just installed Hyperspin 1.4. Configured my joystick in HypeHQ (was able to set all keys) but then i launch Hyperspin the only thing what works is enter and esc buttons.

Share this post


Link to post
Share on other sites

Have same issue. Just installed Hyperspin 1.4. Configured my joystick in HypeHQ (was able to set all keys) but then i launch Hyperspin the only thing what works is enter and esc buttons.

 

I think you don't use HYperHQ if you are using a controller - disable it in fact. The script is what you need. Let me know if you need anything - I'm focussed on my Android Hyperspin and haven't looked at my PC Hyperspin for ages. I am pretty sure my PC hyperspin is fully working though so if I have anything that will help I will send it you.

Share this post


Link to post
Share on other sites

I'm having a similar issue... But mine all works play a game and on return to menu nothing works. I do run startup script and joy2key. I have checked and it's not losing focus the keyboard and keys just don't work.... I have to hit ctrl alt delete

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...