Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Announcement

    Sorry for the recent downtime. Still much to do but we have the site updated, secure and back online.  Expect more changes.

Hyperpin no longer works with the last Nvidia Shield Update


fred33

Recommended Posts

If hyperspin developpers don't have time or don't know how to do this android 11 update.

So yes why don't ask help to others interesting developpers, or just paid some developpers for do the job.

I think the hyperspin community can give some money for do this update and many people would be happy for a new working hyperspin version.

It's an idea, but please do something, don't let hyperspin die.

 

Link to comment
Share on other sites

I've been using Hyperspin on and off for builds longer than some kids have been alive... I was looking forward to installing Hyperspin on my new Shield TV today, only to discover it's not compatible with the latest update.

I'm glad I found this discussion, but sad to see @reznnate seems to have given up. I understand the update isn't a small undertaking, but I'm one of those who would have been willing to pay, if it meant Hyperspin could live on. Most other front-ends suck and/or feel derivative, but I guess they'll get my attention now, by default.  

Link to comment
Share on other sites

I had nearly given up due to the number of Android OS and SDK changes.    Fortunately things are moving forward again and an update is looking likely.... soon too.      Sorry it's taken so long.

  • Like 1
  • Upvote 1
  • Super Like 5
Link to comment
Share on other sites

8 hours ago, reznnate said:

I had nearly given up due to the number of Android OS and SDK changes.    Fortunately things are moving forward again and an update is looking likely.... soon too.      Sorry it's taken so long.

i never give'd up on you!
cheers mate, u made my f**** day!! 😍

Link to comment
Share on other sites

I've been out of the scene for awhile and was wondering if new issues or emulator launch problems have cropped up.    Are there patches or workarounds to consider?

Link to comment
Share on other sites

In case you give up, don't want to, but in case, can you offer us an alternative by opening source ? We really don't want hyperspin to die, anyway thx to give hope again !

Edit : By the way can we participate to help you ? Money ?

Link to comment
Share on other sites

Okay, I'm going to attach a test build here for the sake of quick feedback.   

LOTS of things have changed under the hood (including an arm64 binary) so let me know if you run into problems.   
Almost all the issues I've been hitting (while testing at this point) are related to emulator behavior, issues with my old config/.ini files, etc.     Also, this build includes the change suggested by Hyperseeder for better support of the different Retroarch versions.

-Reznnate

Hyperspin-test-July22.apk

  • Like 2
  • Upvote 1
  • Super Like 3
Link to comment
Share on other sites

Just gave it shot and things seem to be working for the most part. All good with retroarch anyway but I think I need some tweaking on some of my stand alone emulators. Thanks for working on this Rez and keeping this alive, your efforts are very much appreciated!!

Link to comment
Share on other sites

#my2022hero

Ok, first what a pleasure to see my intro video  😪 thx !

As you say lots of emulator don't work anymore but retroarch plus works ! A lot of updates are needed in config files.

I have problems with videos themes that are above 100meg, that's new. maybe by updating the ffmpeg package as we can see in the "about" button the version is 2.1. and in this about button you can wrote your name for sure !

When i want to navigate with r triger to choose letters it's crashing

Honestly if you can change the logo 😅

It's a big win for me, i spent so many time on this and thx again

Link to comment
Share on other sites

9 hours ago, reznnate said:

Okay, I'm going to attach a test build here for the sake of quick feedback.   

LOTS of things have changed under the hood (including an arm64 binary) so let me know if you run into problems.   
Almost all the issues I've been hitting (while testing at this point) are related to emulator behavior, issues with my old config/.ini files, etc.     Also, this build includes the change suggested by Hyperseeder for better support of the different Retroarch versions.

-Reznnate

Hyperspin-test-July22.apk 17.59 MB · 4 downloads

Didnt expected this fast :)
Thank u so much for that.
i'm gonna try this out with the Nvidia Shield and the 9.1 Update.

Recently the Standalone Emulators got Updated and almost everything is running back like in 8.2.3
maybe @HyperSeederknows more about the emulator behaviors.

 

i will post my results after testing the next days.

Link to comment
Share on other sites

Let me know if you find issues.   As stated above, most issues I'm hitting involve Android's update and impact to emulators and external storage access/permissions, etc.    

  • Like 1
Link to comment
Share on other sites

Hi, as i say, navigation by letters is crashing, and large mp4 vids don't play well. Is there a way to use vlc instead like in other front end ?

Some emulators are still ok like retroarch plus, but others like nes emu, snes9x,mupen 64,yabasanshiro,redream and others don't work, they works alone so it's the adress in .ini that is no more right, pspp seems to add a "/" in the rom path so don't work neither.

I think a list would help everybody.

I'm on a shield with factory reset on last 9.1.

 

THX !

Link to comment
Share on other sites

Let me know if you find something in hyperspin changed (possible, but less likely) or if it's related to .ini or those emulators behaving differently.   For example, I've noticed emulators that haven't been updated cannot properly browse external media.   😞     Be sure the emulators have permissions giving them access to external storage (in Android TV settings->apps->permissions)

In summary.... some of the key changes made for this build of Hyperspin include:

1. both 32b and 64b binaries... meaning that new 64b libraries (ffmpeg) are used as well (on Shield TV pro).     

2. updated Android sdk version and life-cycle that addresses launch/return behavior and changes to external storage behavior and permissions

3. a few bug fixes

  • Like 1
Link to comment
Share on other sites

HI did someone know where is gone "exe=com.explusalpha.Snes9xPlus/com.imagine.BaseActivity"

I think i will be the same process for others emulators who don't work

That's strange that some others still works 

Link to comment
Share on other sites

Great stuff :). It's great to see HS making an official comeback.

Unfortunately my Shield has broken down and I ended up replacing it with a NUC, so I can't help much with beta testing ATM.

@TheBandit may actually be someone well equipped to help as his collection uses quite a few standalone emulators, as well as multiple 32-bit and 64-bit RA cores.

It would be great if someone could compile a list of working settings for modern emulators.

The ones for RA can be found bellow:

Main APK from RetroArch's website and Google Play Store Version:

exe=com.retroarch/com.retroarch.browser.retroactivity.RetroActivityFuture

RetroArch's website 32bit version:

exe=com.retroarch.ra32/com.retroarch.browser.retroactivity.RetroActivityFuture

RetroArch's website 64bit version and RetroArch Plus:

exe=com.retroarch.aarch64/com.retroarch.browser.retroactivity.RetroActivityFuture

Also let me know when the new version hits Google Play Store and I'll take down the modded version.

 

Link to comment
Share on other sites

I've been testing as well and have found issues with launching a few standalone emulators -- c64.emu, Redream, and PPSSPP.   PPSSPP launches  but won't load game.   

I've also been testing arm64 Retroarch cores and these don't seem to work (for me):  freeintv, snesx, flycast, and mupen64plus_next_gles3.

I've hit a crash issue with a Cave theme that worked previously.   It uses a background.swf causing a crash (and may be raising a 64b issue).

Link to comment
Share on other sites

6 hours ago, reznnate said:

I've also been testing arm64 Retroarch cores and these don't seem to work (for me):  freeintv, snesx, flycast, and mupen64plus_next_gles3.

Do they work if you launch them directly from RA? Some of the aarch64 cores were hit-or-miss for me even before the update. I'm pretty certain that I was using 32 bits RA for SNES and standalone M64 Plus FZ for N64. I'm not sure about Flycast as I moved to Redream... I think that the 64 bits version used to work but the 32 bits was faster (but don't quote me on that).

Link to comment
Share on other sites

Big Thanks for this update

I can help for test retroarch's website and all my stand alone emulator

But i have a problems...

Before, when hyperspin work again, i haved put hyperspin folder on my NAS with this install help

i haved choose /sdcard1/Hyperspin

On my synologyNAS in the SMB config, i created an SMB alias sdcard1 (so my DISKSTATION2=SDCARD1)

So all my path to hyperspin and rom become rompath=/storage/sdcard1/Hyperspin... in all the .ini file

Work great before

I have installed your new apk, shield ask me for update hyperspin app, clicked OK

But after when i launch i have a black screen then hyperspin closed

I decided to delete the old hyperspin folder to the shield because the new hyperspin folder is now in android/data folder

Then when i relaunch hyperspin i have the message "no hyperspin folder ?" and choice is <UUID> or sdcard or sdcard0 but now their is no SDCARD1 in possibly choice ???

sdcard1 disapear ? we can't use sdcard1 as before ???

So i modified my NAS alias sdcard1 to sdcard0 in the NAS smb.conf and restart NAS and put the share network link in the shield

With X-plore i can access all the files OK

I launch again Hyperspin and allways this stupid message "no hyperspin folder found"

Desintalled end reinstalled Hyperspin and put again authorisation and same add authorisation for NAS access, allways this message appears

Hyperspin don't found "storage/sdcard0/Hyperspin" and in x-plore i have access to "storage/sdcard0/Hyperspin" ???

Thanks for your help

Link to comment
Share on other sites

Firstly, thanks reznnate for your work on this.  I am also running into the same issue as moondefer.  I used to be able to run Hyperspin from a share on my NAS but now I get the "No Hyperspin Data Folder Found!" error.

Link to comment
Share on other sites

I'm late to the party, but THANK YOU, @reznnate for resuming work on this! 

Of course, the irony is that I've just spent the better part of the last week getting ArcBrowser setup with a whole bunch of standalone emulators (mostly the Robert Broglia packaged standalones... Retroarch is missing some cores and just feels bloated). Even so, I fully expect Hyperspin could work with the majority of my assets, assuming emulator compatibility gets sorted! 

I'll be installing the test .apk tonight!

Kudos!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...