Jump to content

Recommended Posts

Hey Guys I know this isn't really a Hyperspin problem but I was hopeing someone has set up their PS3 controller on the shield without the problems I'm having.

I can get the pad working fine with everything plugged in or using Bluetooth (HyperSpin, KODI, etc) but the red lights are constantly flashing (trying to link to something?) if I turn off my Shiled the lights carry on flashing until the battery dies in the controller.
Is this normal?

When I turn on the Shield TV after the lights go out (the following day) I have to re plug in the controller using the USB & re connect it all over again which is a pain each time I want to use it as a normal navigation control.

 

Thanks for the help

Share this post


Link to post
Share on other sites

I'm not sure why the PS3 controller does this but I've definitely seen this behavior as well.    On Shield, it's been the consistent behavior across Android L->M->N and now Android O.

It would be interesting to note if it's different on Windows, Mac, or other Android devices.

 

 

   

Share this post


Link to post
Share on other sites

I did setup my PS3 controller on the Shield natively recently and noticed the lights flash all the time.

its not my main controller and I always turn it off not not caused me any issues.

I have been busy with other stuff recently so not had the Shield on for a couple of weeks :( will be off for a while yet I expect

Share this post


Link to post
Share on other sites

thatman - what do you mean by ' and I always turn it off not not caused me any issues. '  Do you mean turn the pad off? How do you turn it off the little button underneath?
 

Thanks

Share this post


Link to post
Share on other sites

I just hold the PS button down until the lights go off.

But actually just testing it the 1 LED came on solid. (My shield is probably the only thing on right now, kid is watching TV though so cant check connection) so maybe I dont have the flaahing issue. I update to Oreo a couple of days ago

 

Share this post


Link to post
Share on other sites

Ah so Oreo might fix this as that's how it should work!
When you get the TV back can you check please mate as I haven't updated yet.

Share this post


Link to post
Share on other sites

Just had it on and confirmed number 1 led is solid for the pad. I am almost certain all lights flashed constantly before the update.

also I read with Shield experience 7 that they worked on ds4 compatibility so could be an upshot of that work

Share this post


Link to post
Share on other sites

Ok I updated to Oreo (poo new layout).  I tried to install my PS3 pad & got the same result of the 4 flashing lights so I tried my other pad.
This time the other pad worked & conected but the name wasn't Playstation3(sixaxis) it was just conected where the other pad came up with a full name but didn't work!
So a bit confusing but it seems to be working with the other pad fine now although no lights come up on the working pad but I guess thats ok.
I just renamed the working pad to PS3_1 but I still couldn't connect the old pad correctly.  I tried resetting it & connecting back to my PS3 but still the same result so no idea.  At least one is working now.

Thanks

Share this post


Link to post
Share on other sites

Weird what was your process of connecting. I think i had to connect with usb to pair 1st time 

Share this post


Link to post
Share on other sites

Yeah you have to go to
Settings - Add accessory - then hit the PS button on the pad to get it into Blutooth search - then I plugged it in & it connected.
But doing it various other ways on the old pad I've been asked for a PS number for the pad or it works plugged in then works through bluetooth but when you restart it disapears from the list & you have to re pair it.
Sometimes the full name comes up or just says connected sometimes it comes up on the list of things to connect soemtimes it just works even though it never appears on the connection list.

Share this post


Link to post
Share on other sites

Actually I've just tried the pad & the one that is working now has the flashing 4 lights again so I've no idea what I'm doing wrong it was working this morning!

Share this post


Link to post
Share on other sites

I would probably put it down to buggy android/shield handeling of PS3 pads

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By thatman84
      Hyperspin Android ScummVM with RetroArch
      Credits
      JLeaver
      Norkusa
      reznnate
      badhemi
      sting
      honosuseri
      sanchezmike01
      aftermath17
      Pouteur
      krater9
       
      What is it?
      ScummVM is a program which allows you to run certain classic graphical point-and-click adventure games, provided you already have their data files. The clever part about this: ScummVM just replaces the executables shipped with the games, allowing you to play them on systems for which they were never designed!
      Assets and Links
      Latest ScummVM release at time of posting Dec 17, 2017: ScummVM 2.0.
      Diskmach Updated Database ScummVM 2.1
      Latest HyperSpin database ScummVM 1.8

      Working RetroArch core at time of posting scummvm 2.0.0 93d1ca1
      Location of current core
       
      How to setup...
      Grab these setup files as they will be needed.
      (Includes the Android XML and "Official" XML databases)
      Follow this guide to set up RetroArch ScummVM core directly Get your games and place them in folders named after this spreadsheet OR download the above setup files and create folders for them (with help of the below guide) Follow this guide to setup the folder structure for Hyperspin Android "folder trick" Use the below ini file settings for reference and add the system to your Hyperspin wheel as any other exe=com.retroarch/com.retroarch.browser.retroactivity.RetroActivityFuture
      romextension=scummvm
      parameters=cores/scummvm_libretro_android.so
      Run Hypersync with the NON android xml as its not compatible with sync.
      The progress sheet below was adopted on the RetroArch documentaion and holds all my findings. I did duplicate 1 game to aid with android setup
      I created a "simon" folder for the Simon the Sorcerer's Puzzle Pack as all the games are in one folder.
       

      Backup of Working Core
      scummvm_libretro_android.so.zip
      Helpful Links
      https://github.com/scummvm/scummvm/tree/master/dists/engine-data
      https://www.scummvm.org/
      https://www.scummvm.org/compatibility/2.0.0/
      http://wiki.scummvm.org/index.php/Datafiles
    • By DrSoupants
      Dear Hyperspin Community. 
      Before I go any further, can I please apologise for posting this request for information. I have no doubt that this has been covered thousands of times on thousands of posts on this website and I am indeed sorry. Feel free to scream at me profusely and use a range of poo emojis to communicate your frustration with me. I guess I'm a little overwhelmed with all of the content and I'm a bit unsure where to start. I'm definitely new to Hyperspin and need some help. 
      I have an Nvidia Shield, complete rom packs (at least I think they're complete) for a range of consoles, have the Retroarch emulator working and have a range of other emulators to play all of the games I want. I have a 2TB hard drive that am using as shared (or emulated) storage device and this is dedicated to the shield (non-removable). Ok......this is where you get pissed. 
      1.) Hyperspin tells me "Warning.....attempting to launch missing rom". Because my HD is emulated the path in ES explorer reads: 'storage/emulated/0/hyperspin/emulators ( …….then all of the console folders (eg: MAME)……. then all the rom folder)'.  Roms are placed in this folder. Can someone please tell me what I need to write in the individual setting file (eg: Nintendo 64.ini)  as I have had no luck at all with any of the games on the Hyperspin interface. I believe this to be my major problem. 
      2.) This is where you're really going to get the shits. I downloaded the base pack for the Nvidia Shield (from the Hyperspin site) and the start menu is great. When I enter a console I have a warning triangle telling me "Video Previews available at emumovies.com". How do I sinc the videos with the individual menus (I think they are referred to as 'systems' but I have no idea how to install these)???????? Soooo...……..where can I find these and how and where do I install them??
      3.) I believe that the fonts and images associated with roms are called 'wheels'. I have downloaded a few of these but how would I install these on the shield? 
      Basically, what I'm asking is...……... how can I setup Hyperspin on the Shield using a shared storage device so that it kicks some serious ass. 
      A huge thank you for anyone that can help me. Feel free to kick my ass in the comments but I've already done that over the past couple of weeks so I'm well ahead of you.
      Thank you so much Hyperspin and hope to hear from you soon. 
      Soup Pants. 
    • By reznnate
      Tested Emulators -- .ini config settings   Retroarch - Various emulators   exe=com.retroarch/com.retroarch.browser.retroactivity.RetroActivityFuture  parameters=<choose one of the emulator cores like below>   Examples of retroarch core parameters Atari 2600 core:  parameters=cores/stella_libretro_android.so PSX core:  parameters=cores/pcsx_rearmed_libretro_neon_android.so   libretro cores:  4do_libretro_android.so  bsnes_mercury_performance_libretro_android.so  bsnes_performance_libretro_android.so etc...     Dolphin - Gamecube/Wii/Wiiware exe=org.dolphinemu.dolphinemu/org.dolphinemu.dolphinemu.activities.MainActivity parameters=AutoStartFile    Newer Builds from Dolphin Website:-   exe=org.dolphinemu.dolphinemu/org.dolphinemu.dolphinemu.ui.main.MainActivity parameters=AutoStartFile    IrataJaguar - Atari Jaguar  exe=ru.vastness.altmer.iratajaguar/ru.vastness.altmer.iratajaguar.MainActivity  parameters=rom   Real3DOPlayer - 3DO  exe=ru.vastness.altmer.real3doplayer/ru.vastness.altmer.real3doplayer.MainActivity  parameters=cd   NES.emu - NES  exe=com.explusalpha.NesEmu/com.imagine.BaseActivity  parameters=   MSX.emu - Colecovision, MSX, etc.  exe=com.explusalpha.MsxEmu/com.imagine.BaseActivity  parameters=   Mame4Droid - MAME  exe=com.seleuco.mame4droid/com.seleuco.mame4droid.MAME4droid  parameters=   Mupen64Plus AE exe=paulscode.android.mupen64plus/paulscode.android.mupen64plusae.MainActivity
      parameters=    Nightly builds exe=org.mupen64plusae.v3.alpha/paulscode.android.mupen64plusae.SplashActivity parameters=     Play! - Playstation 2 exe=com.virtualapplications.play/com.virtualapplications.play.ExternalEmulatorLauncher parameters=   Reicast - Dreamcast  exe=com.reicast.emulator/com.reicast.emulator.MainActivity  parameters=   Drastic - Nintendo DS  exe=com.dsemu.drastic/com.dsemu.drastic.DraSticActivity  parameters=GAMEPATH   Fpse - PSX  exe=com.emulator.fpse/com.emulator.fpse.Main  parameters=path   ePSX - PSX  exe=com.epsxe.ePSXe/com.epsxe.ePSXe.ePSXe   parameters=com.epsxe.ePSXe.isoName  * change romext=cue in settings.ini, iso did not work for me   PPSSPP (FREE version) - PSP  exe=org.ppsspp.ppsspp/org.ppsspp.ppsspp.PpssppActivity  parameters=org.ppsspp.ppsspp.Shortcuts PPSSPP Gold - PSP             exe=org.ppsspp.ppssppgold/org.ppsspp.ppsspp.PpssppActivity              parameters=   uoYabause - Sega Saturn exe=org.uoyabause.android/org.uoyabause.android.Yabause
      parameters=org.uoyabause.android.FileNameEx
      Yaba Sanshiro
               exe=org.uoyabause.uranus/org.uoyabause.android.Yabause
               parameters=org.uoyabause.android.FileNameEx
      Gearoid - Sega Game Gear  exe=com.androidemu.gg/com.androidemu.gg.EmulatorActivity   Parameters=   Colem - Speccy ZX - fMSX VGBANext  Emulators from Garage Research  PAID  com.fms.colem.deluxe - Colem - Colecovision  com.fms.fmsx.deluxe - fMSX  com.fms.ines - iNES  com.fms.emu - VGBAnext - GBA/GBC/GB Emulator  com.fms.vgb - VGBc - Gameboy Color  com.fms.mg - Master Gear - Sega Game Gear  com.fms.speccy.deluxe - Spectrum Sinclair ZX  FREE  com.fms.colem  com.fms.fmsx  com.fms.speccy    Set "??" to "com.fms.emulib.MainActivity" for all products but VGBAnext.   For VGBAnext:  ??=com.fms.vgba.MainActivity for opening *.gba files  ??=com.fms.vgb.MainActivity for opening *.gbc/*.gb files   OpenBOR - 2D Game Engine (Some integration issues with Hyperspin)              exe=org.openbor.engine/org.libsdl.app.SDLActivity Parameters=   Launch android app package names in database.xml Determine Android game name through Google Play web interface. i.e. https://play.google....ure.dragonslair   pcgame=true
×