Jump to content
HyperSync, HyperList and FTP are now back online ×
Hyperion

winipac won't "program" keys and won't hold button presses

Recommended Posts

Hi Hyperspin Fans,

I'm trying to setup my arcade controls for the first time and I'm having a lot of trouble with winipac, the setup utility for my ipac4.

I can setup my control panel layout fine and save it. I can even setup my desired key map and save that too. The problem is when I try to "program" the ipac with these changes I get an error and a message advising me to reinstall with the ipac plugged in and/or reboot. At first the error was that the driver wouldn't load but after running winipac in XP service pack 2 comparability mode the driver loads but the still programming fails.

I've tried this several times and even downloaded the latest ultimarc winipac which happened to be the same version on the disc.

The reason why I want to change the key map is because the first four buttons on player one are defaulted to stuff like shift, ctrl alt and space which as far as I can tell are pretty much unusable.

Another problem I'm having is that button presses only stay held down for about a second. Meaning if I'm playing a platformer, for example, and I want to move from left to right I hold down "right" but after a second the character stops and I have to return the joystick to the neutral position and then press right again to get my character to move right for another second. Same goes for any other button.

OS: Windows 7 64bit

Ipac4 via usb.

Winipac running in XP service pack 2 compatibility mode and as administrator

SOLVED:

See this post for the solution to the programming issues.

See this post for the solution to the buttons not staying held down problem.

Edited by Hyperion
SOLVED

Share this post


Link to post
Share on other sites

When I say that the ipac4 is connected via usb, I mean I have a usb to ps2 adapter that I have plugged into the ps2 in on the ipac4. I wasn't sure if this what winipac means when it asks whether the ipac is connected via ps2 or usb so I tried the ps2 setting and the programming starts then times out every time.

SOLVED:

It's definitely USB mode using this configuration.

Edited by Hyperion

Share this post


Link to post
Share on other sites

Should I not worry about changing the default key map and "just" translate the key presses in something like a hyperlaunch ini?

Has anyone else had the same problem I have with keys not staying held?

Share this post


Link to post
Share on other sites

I don't have the key press issue you describe, but I do have the same issue and error message when trying to program the ipac4 under Windows 7 x64. I also noticed the WinIpac utility GUI has a strange window border cutting vertically through the panel layout. I have had no luck resolving getting this thing to program, so I am also anxious to hear if someone knows of a solution. I am also on the latest version of the WinIpac software, and have also tried some older versions that I had saved with no luck. Hyperion, If you find something, please share.

Share this post


Link to post
Share on other sites

Nice to know that someone else is having similar difficulty with programming. I haven't noticed the weird window border you described though.

I haven't had any progress yet.

I also noticed that the default key map uses "v" for player 1's switch 8, I think, which is also mapped to player 3's joystick left. That can't be right.

I'm also having problems with player 1 switch 1 which is mapped to left ctrl. It sometimes sticks and also randomly changes to right ctrl which is mapped to player 3's controls. This same phenomenon occurs with other buttons mapped to the shift and alt keys.

I've googled the crap out of this with no working solution yet.

Edited by Hyperion

Share this post


Link to post
Share on other sites

I don't know if I just noticed it or it's a new development but about a fifth of the buttons share key assignments. What does this mean? Could be a symptom of the root cause of all my troubles? Does anyone know what's going on?

I've already emailed Andy from Ultimarc but I probably won't hear from him till Monday at least.

Share this post


Link to post
Share on other sites

Have you kept your grounds separate for player 1 and player 2. Also make sure you obviously wireing to normally open and not normally closed on your switches...

Share this post


Link to post
Share on other sites
If it was me id just consentrate on one side at a time. Wire up player 1 first and test..

Thanks for the feedback, richie. I've received an email response from Andy of Ultimarc fame and he's pretty sure the problem is being caused by using a PS/2 to USB converter instead of just an adapter. I'll pick up an adapter tomorrow and see how we go.

Buying Ultimarc's or in my case Ozstick's official usb adapter would have saved me a lot of time and heartache. :shot:

Share this post


Link to post
Share on other sites

I've fitted a new PS/2 to USB adapter but only half of my woes have been remedied. The buttons now hold down nicely but I still can't successfully program a new key map.

Ctrl, shift and alt keys still sometimes alternate between their left and right versions of themselves.

About 20% of the buttons still share a key map with another button. If it wasn't because of the this broken default key map I could live with not being to reprogram but as it is it's unusable.

With the new PS/2 to USB adapter I been able to use the ctrl-alt-p method to access the key map through DOS. The DOS test mode has confirmed that my wiring all lines up correctly but even in DOS mode it is unable to save any attempts to reprogram the key map.

Share this post


Link to post
Share on other sites

I had a very similar issue. Basically the older Ipacs pre July/Aug 2012 use a driver model and therefore are OS dependent. I could only use win7 32bit to program mine. Programming in the DOS mode would never stick and I had issues programming in XP64 as well. I would basically have to program using the GUI in windows 7 and then move the Ipac to my XP machine (A long USB cord helped this). Andy offered to upgrade my firmware if I sent it back in but for me it was not a huge issue (The firmware upgrade would have made the Ipac OS independent and give it windows API functions as well). I know this does not help, but I want you to know you are not alone and there is hope.

In the GUI settings do you have the Ipac set to USB and not PS/2? I think default is PS/2.

Share this post


Link to post
Share on other sites
I had a very similar issue. Basically the older Ipacs pre July/Aug 2012 use a driver model and therefore are OS dependent. I could only use win7 32bit to program mine. Programming in the DOS mode would never stick and I had issues programming in XP64 as well. I would basically have to program using the GUI in windows 7 and then move the Ipac to my XP machine (A long USB cord helped this). Andy offered to upgrade my firmware if I sent it back in but for me it was not a huge issue (The firmware upgrade would have made the Ipac OS independent and give it windows API functions as well). I know this does not help, but I want you to know you are not alone and there is hope.

In the GUI settings do you have the Ipac set to USB and not PS/2? I think default is PS/2.

So you're saying that it might work to use another computer like a laptop that has a 32bit OS to program it then it should work... Interesting...

I wonder why was the default key map was so stuffed up in the first place?

Oh and to answer your question, I've tried both USB and PS/2 modes in the settings. USB mode "fails" and PS/2 "times out".

Share this post


Link to post
Share on other sites

ya, another OS is worth a try. I do not know if 32bit matters, but I know it only worked on my win 7 32bit and not xp64 (Although I think Andy told me they never tested XP with the newer stuff). Also, I think there is a bios setting for USB ports that needs to be set to legacy or maybe vice versa. It's in the troubleshooting docks.

Share this post


Link to post
Share on other sites

I had to run winipac as administrator to get it to program at all. Thought I would throw that out there.

Share this post


Link to post
Share on other sites
ya, another OS is worth a try. I do not know if 32bit matters, but I know it only worked on my win 7 32bit and not xp64 (Although I think Andy told me they never tested XP with the newer stuff). Also, I think there is a bios setting for USB ports that needs to be set to legacy or maybe vice versa. It's in the troubleshooting docks.

:party:AAAAAAAAAAAAAAAHAHAHAHAHAHAHAHAAA!!!!!!!!! Success! Success! Success! :party:

Thank you so much, somail!! You - are - a - lifesaver! I used a 32bit win7 laptop to program the i-pac through winipac with great success. The 32bit win7 wouldn't program through ctrl-alt-p in DOS and it couldn't type in wordpad with the arcade controls but it would program with no trouble which was the main thing. I hooked the i-pac4 back up to my win7 64bit arcade PC and it worked perfectly!

Thanks again, somail. :D

Edited by Hyperion

Share this post


Link to post
Share on other sites
I had to run winipac as administrator to get it to program at all. Thought I would throw that out there.

I did this before and it did help the driver get to the loading stage but ultimately failed. Thanks Boomer.

Share this post


Link to post
Share on other sites

I have a strange problem with my Ipac4. The player 1 start button is assigned to #1 (not the number pad, under F1 key) which is what it is set to by default. The problem is when I press and hold the button down, nothing happens, it is triggered only when I release (depress) the button. All my other buttons are the opposite. It is wired correctly and I have tried different cherry switches with no luck. I'm wondering if there is a way this can be programmed? Thanks

Share this post


Link to post
Share on other sites
I have a strange problem with my Ipac4. The player 1 start button is assigned to #1 (not the number pad, under F1 key) which is what it is set to by default. The problem is when I press and hold the button down, nothing happens, it is triggered only when I release (depress) the button. All my other buttons are the opposite. It is wired correctly and I have tried different cherry switches with no luck. I'm wondering if there is a way this can be programmed? Thanks

The reason why it is behaving that way is because your P1 start button is the default "shift" button which when held enables alternative key maps for all the other buttons. You can nominate another button to be "shift" instead and you have to program most of the buttons alternative key maps.

If you need more clarification just ask. :)

Share this post


Link to post
Share on other sites
The reason why it is behaving that way is because your P1 start button is the default "shift" button which when held enables alternative key maps for all the other buttons. You can nominate another button to be "shift" instead and you have to program most of the buttons alternative key maps.

If you need more clarification just ask. :)

Where is that option to change the shift key?

Share this post


Link to post
Share on other sites

Open winipac and go to the key mapping mode (I'm not sure if it's actually called that but it's the mode that's not the control panel editor). The easiest way is to select the "table" view which shows the key map in a form of a table/spreadsheet. At the top left of the table there is the field for the P1 and P2 shift button. Half way down the table and to the left is the field for the P3 and P4 shift button. To change these click on the existing field and then press the desired new shift button on your control panel.

To map the alternative keys to the control panel you can use the table in the same way as I described above to do so (green fields is the primary key map and purple fields is the secondary/alternative/shifted key map) but I find it easier to switch back to the panel view where you can see your virtual control panel and then select the shifted keys mode. This is more intuitive to me when designing the key map.

I haven't tried it but I think you can make it so there isn't a shift button at all if you want. I suspect you can by switching to panel view within key mapping mode and then right click on the existing shift key then select "none".

Share this post


Link to post
Share on other sites

I just wanna say "thank you" for posting the solving of the problem directly into the first post. This is how problem-fixing should be documented. Many thanks.

Share this post


Link to post
Share on other sites
On 1/20/2013 at 8:52 PM, richie_jones said:

Have you kept your grounds separate for player 1 and player 2. Also make sure you obviously wireing to normally open and not normally closed on your switches...

 

Is this important to wire grounding separate ? What do you mean by open and not close on switches?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...