Jump to content
fr0stbyt3

Hyperbase Live: Public Beta

Recommended Posts

And Unless I have screwed up on the install I don't have any way of adding any video.

 

Of course you screwed up Giga :teehee:. You have to provide your EmuMovies login under Settings -> Emumovies in order for the video options to show up.

 

In other news, I found a bug due to my stupidity. I selected the High Quality mp4 option to sync for N64, but I don't have a Platinum membership over at EmuMovies, so I can't download them. HBL says it's starting to sync, then I guess times out, and tries again 2 minutes later. It's been doing that for over 15 minutes.

 

So you may want to have a credentials check for the HQ option that throws an error message telling the user they need to purchase a membership over at EM with a link to do so and not allow the sync to take place.

 

 

Sync Started for Nintendo 64

03/16/2016 at 4:35PM
Sync Started for Nintendo 64
03/16/2016 at 4:33PM
Sync Started for Nintendo 64
03/16/2016 at 4:31PM
Sync Started for Nintendo 64
03/16/2016 at 4:29PM
Sync Started for Nintendo 64
03/16/2016 at 4:27PM
Sync Started for Nintendo 64
03/16/2016 at 4:25PM
Sync Started for Nintendo 64
03/16/2016 at 4:23PM
Sync Started for Nintendo 64
03/16/2016 at 4:21PM
Sync Started for Nintendo 64
03/16/2016 at 4:19PM
Sync Started for Nintendo 64
03/16/2016 at 4:17PM
Sync Started for Nintendo 64
03/16/2016 at 4:15PM
  • Upvote 2

Share this post


Link to post
Share on other sites

I'm going to write this as I go along and some of the points are minor and are just observations.

 

Is the installer really well packed or is it downloading from somewhere? It's 76mb and needed 276mb or something. Just curious on that one.

 

  1. No browse button to set HS path so I copied and pasted.
  2. So there is no actual sync button? Once I add what I want download and save it syncs straight away? Or is that orange button a sync or resync button. Is it possible for the name of that button to pop up if I hover over it?
  3. If I enter a system and don't make changes I have to press save or click "All Systems", I can't just press "esc" to go back?
  4. And Unless I have screwed up on the install I don't have any way of adding any video.

So those are things I picked up on as I was playing as someone who knows nothing about this software, pretending as if I'm a general user. 

Great work Fr0sty, love it.

 

  1. On the todo!
  2. I can add a hover effect. Currently its all or nothing for sync.
  3. No key handler for go back. I like this idea though. I'll add it to the list.
  4. Check EmuMovies under settings

Share this post


Link to post
Share on other sites

 

So you may want to have a credentials check for the HQ option that throws an error message telling the user they need to purchase a membership over at EM with a link to do so and not allow the sync to take place.

 

 

HAH! I suppose I never tested with an account that was real but not the correct level. 

  • Upvote 1

Share this post


Link to post
Share on other sites

Of course you screwed up Giga :teehee:. You have to provide your EmuMovies login under Settings -> Emumovies in order for the video options to show up.

 

 

I may be dumb but I have done that, it is possible that I have used the wrong password but there is nothing to tell me that. So I will need to unlink and try again.

 

post-2819-0-25020400-1458161092_thumb.jp

Share this post


Link to post
Share on other sites

I may be dumb but I have done that, it is possible that I have used the wrong password but there is nothing to tell me that. So I will need to unlink and try again.

 

attachicon.gifImage 1.jpg

 

looks like a bug, unlink your emumovies then link again, there should then be a path listed there

Share this post


Link to post
Share on other sites

HAH! I suppose I never tested with an account that was real but not the correct level. 

 

Related to that, have you implemented a check/handling for when a non-Plat member has hit their download allowance for the day? I have a 1GB daily download limit so you would need to handle what happens when EM rejects my download due to me reaching that limit, which could happen mid sync, and block future sync attempts for the day and show a message to notify the user.

 

It may also be good idea to show the EM member level and/or remaining daily download allowance similar to how you have the HS member level displayed.

Share this post


Link to post
Share on other sites

Related to that, have you implemented a check/handling for when a non-Plat member has hit their download allowance for the day? I have a 1GB daily download limit so you would need to handle what happens when EM rejects my download due to me reaching that limit, which could happen mid sync, and block future sync attempts for the day and show a message to notify the user.

 

It may also be good idea to show the EM member level and/or remaining daily download allowance similar to how you have the HS member level displayed.

 

Are non paying members for EM able to use DSU? I though you had to be paid member to use that. HyperSync uses the same API as DSU. Are you ableto download videos via HyperSync?

Share this post


Link to post
Share on other sites

Are non paying members for EM able to use DSU? I though you had to be paid member to use that. HyperSync uses the same API as DSU. Are you ableto download videos via HyperSync?

 

Looks like you can. Chris will just need to catch this exception when it comes up in communication

Share this post


Link to post
Share on other sites

Looks like you can. Chris will just need to catch this exception when it comes up in communication

 

I just tested it and I can't download the SQ vids, it gave me the sync loop every 2 minutes just like when I tried to download the HQ vids. But, I can download the PNG snaps.

  • Upvote 1

Share this post


Link to post
Share on other sites

I will add that to my test cases. Thanks!

 

No problem, I'll see what else I can break.

Share this post


Link to post
Share on other sites

ok its stopped again and this keeps happening as it syncs through 

 

as you can see its stopped at 7:12 where it is 7:27am now 

 

 
photo-862.jpg
relicPlatinum Member

Systems

View All

Sync Logs

 
 

Settings

 
 
Sync Logs
 
Downloading Video: Ogre Battle - The March of the Black Queen (USA).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
Downloading box : Exertainment Mountain Bike Rally & Speed Racer (USA).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
Downloading cart : SimAnt (USA).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
Downloading cart : SimEarth - The Living Planet (USA).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
Downloading cart : Rocko's Modern Life - Spunky's Dangerous Day (USA).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
Downloading Video: On the Ball (USA).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
Downloading cart : SimCity 2000 (USA).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
Downloading box : Flintstones, The (USA).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
Downloading cart : Smurfs Travel the World, The (Europe).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
Downloading Video: Push-Over (USA).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
Downloading cart : Shadowrun (USA).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
Downloading cart : Roger Clemens' MVP Baseball (USA) (Rev 1).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
Downloading Video: Pit-Fighter (USA).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
Downloading Video: Pieces (USA).png from Super Nintendo Entertainment System
03/17/2016 at 7:12AM
 

Share this post


Link to post
Share on other sites

ok so here are the results it seems for videos and snaps it saves in a folder named videos rather then video so thats 1 minor error 

 

another thing i think it was a problem on my end after i set up another system for it to sync through i forgot to press the disk  save icon as it is now syncing sega gensis 

 

so my bad 

 

apart from that im just getting that issue where it syncs through but stops after awhile so you have to keep pressing the big button 

 

my result for sega genesis was diffrent tho it kept syncing with out stopping unlike the snes 

 

another minor bug i found is it shows that its grabbing content which i already have in my folders even so it already synced through the process  - as well as showing that its syncing still even so the process has finished - http://imgur.com/Vnq62Cn

 

and finally ive noticed it downloads videos and snaps twice makeing a folder named videos and one named hyperspin media folder which are the same content 
\Hyper Tech\HyperSpinmedia\Super Nintendo Entertainment System\Videos - as well as this path - Media\Sega Genesis\Videos - http://postimg.org/image/jv5dk1vav/
 
 
Sync Complete for Sega Genesis
03/17/2016 at 8:03AM
Downloading themes : Lion King, The (World).zip from Sega Genesis
03/17/2016 at 8:03AM
Downloading themes : Sonic The Hedgehog 3 (USA).zip from Sega Genesis
03/17/2016 at 8:02AM
Downloading box : Pit-Fighter (World) (Rev A).png from Sega Genesis
03/17/2016 at 8:02AM
Downloading box : Zero the Kamikaze Squirrel (USA).png from Sega Genesis
03/17/2016 at 8:01AM
Downloading box : X-Men (USA).png from Sega Genesis
03/17/2016 at 8:01AM
Downloading box : Xenon 2 - Megablast (Europe).png from Sega Genesis
03/17/2016 at 8:01AM
Downloading box : Zombies Ate My Neighbors (USA).png from Sega Genesis
03/17/2016 at 8:01AM
Downloading box : Zoom! (World).png from Sega Genesis
03/17/2016 at 8:01AM
Downloading themes : Mutant League Football (USA, Europe).zip from Sega Genesis
03/17/2016 at 8:01AM
Downloading box : WWF Royal Rumble (World).png from Sega Genesis
03/17/2016 at 8:01AM
Downloading box : Zero Tolerance (USA, Europe).png from Sega Genesis
03/17/2016 at 8:01AM
Downloading box : WWF WrestleMania - The Arcade Game (USA, Europe).png from Sega Genesis
03/17/2016 at 8:01AM
Downloading box : Wrestle War (Japan, Europe).png from Sega Genesis
03/17/2016 at 8:01AM
Downloading box : Zero Wing (Europe).png from Sega Genesis
03/17/2016 at 8:01AM
Downloading box : World Series Baseball (USA).png from Sega Genesis
03/17/2016 at 8:01AM
 
 

Share this post


Link to post
Share on other sites

I just tested it and I can't download the SQ vids, it gave me the sync loop every 2 minutes just like when I tried to download the HQ vids. But, I can download the PNG snaps.

I just confirmed with Circo that you must be a paid member over at emumovie to sync videos. This is why it's not working. Anyone can sync PNGs with the download limit per day.

Since you are a moderator here you get a free lifetime subscription at emumovies. I will get that set up for you shortly.

Share this post


Link to post
Share on other sites

I just confirmed with Circo that you must be a paid member over at emumovie to sync videos. This is why it's not working. Anyone can sync PNGs with the download limit per day.

Since you are a moderator here you get a free lifetime subscription at emumovies. I will get that set up for you shortly.

 

Yeah I figured that vids were for paying members only. After I tried syncing the HQ vids and got the sync loop I realized that was the case and I just wanted to test the SQ vids from a free account to see if it would produce that same looping behavior.

 

But that free sub is awesome, thanks guys! No rush on that at all, I know there's a lot of stuff going on here and at EM at the moment.

Share this post


Link to post
Share on other sites

nevermind got that working, thanks for this Frosty hope it blows hypersync out of the water though not sure thats possible

Share this post


Link to post
Share on other sites

Yeah I figured that vids were for paying members only. After I tried syncing the HQ vids and got the sync loop I realized that was the case and I just wanted to test the SQ vids from a free account to see if it would produce that same looping behavior.

 

But that free sub is awesome, thanks guys! No rush on that at all, I know there's a lot of stuff going on here and at EM at the moment.

 

This was added to the "features in the works" list. Keep em coming.

Share this post


Link to post
Share on other sites

maybe I missed something, how do you actually get it to download something?  Im logged into both it and emumovies and theres no start button.. Hitting the sync button just says all systems complete in like 10 seconds

 

Did you go into any of the systems and change the configuration settings and click save?

Share this post


Link to post
Share on other sites

Yeah I figured that vids were for paying members only. After I tried syncing the HQ vids and got the sync loop I realized that was the case and I just wanted to test the SQ vids from a free account to see if it would produce that same looping behavior.

 

But that free sub is awesome, thanks guys! No rush on that at all, I know there's a lot of stuff going on here and at EM at the moment.

 

You are all set with the lifetime member over there

  • Upvote 1

Share this post


Link to post
Share on other sites

You are all set with the lifetime member over there

 

Thanks, I appreciate it!

  • Upvote 2

Share this post


Link to post
Share on other sites

have a default button then we can set all systems at once which we have avalible 

  • Upvote 2

Share this post


Link to post
Share on other sites

still hanging for me when i try open it seems to be showing 3 processes running at same time when i end process on them it gives me a black screen in other words it crashes - the only fix for now is to delete this folder C:\Users\leslie\AppData\Roaming\Hyperbase Live - as an example

Share this post


Link to post
Share on other sites

nevermind got that working, thanks for this Frosty hope it blows hypersync out of the water though not sure thats possible

 

Well the first round of features are aimed at bringing back everything you know and love. The second round of new features is where all the awesomesauce comes in.

  • Upvote 2

Share this post


Link to post
Share on other sites

still hanging for me when i try open it seems to be showing 3 processes running at same time when i end process on them it gives me a black screen in other words it crashes - the only fix for now is to delete this folder C:\Users\leslie\AppData\Roaming\Hyperbase Live - as an example

 

Please verify that:

 

You're running from the desktop link.

You've restarted the computer since it first happened.

You have no other instances of the app

Share this post


Link to post
Share on other sites

Hyper-Stoked!

Ima grab a Mt Dew, some Dorritos and give this a testing.

From what I gather, is that Win XP won't be supported on this?

  • Upvote 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...