Jump to content
Sign in to follow this  
BadBoyBill

Table Announcement: Monopoly by PD/BBB

Recommended Posts

Monopoly.png

Here is a full set of artwork and table for Monopoly

Original table by PacDude

Thanks to the PacDude for creating this table and allowing

our modifications and sharing of the file here.

This table has been modififed by BadBoyBill.

HyperPin wheel image by BBB

Thanks to UncleWilly for helping me when needed in VP.

This is basically a mod of PacDude's table, mainly the script, the table itself was pretty much rebuilt from scratch. I fixed a couple issues with the table in the process. So thanks to him for the bulk of the script and his kindness for allowing modifications.

This table has lots of FVP enhancements and detailed artwork

Features:

-Fully traced out playfield, that was probably most of the work.

-High res plastics set and decal set personally scanned by me.

-FVP Plastic ramps and other clear plastics.

-FVP Flasher effects, lighting reflects off other elements on the table.

-FVP Graphics (Gate supports, Signs, Vertical Lighting)

-FVP High res Apron, IC and Coin card.

-Gate microswitches actually move when passing through gates.

-Zoomable instruction card, press the letter "I" and the vectorized -instruction card zooms in big on the screen.

-Updated to JP's version of the Fading lights.

-3D Rendered Bank door for FVP

-Updated the table with animated rollovers.

-All hand drawn hardware throughout the playfield not wall created ones

-Photoshopped rubbers instead of wall type rubbers.

-I used JP style bumpers for the animations but made dropwall bumper caps instead of the built in vp animation

-New plunger animation. I had an extra plunger laying around the house so I snapped off photos of it in various positions.

Press the "I" key to have the Instruction Card zoom in during gameplay.

Mono20.jpg

****IMPORTANT PLEASE READ THOROUGHLY IN ORDER TO RUN THIS TABLE****

STEP 1: Download the toolsack baseline installer here then install:

This is required in order to run FVP enabled tables

http://www.toolsack.com/download/

STEP 2: Download the table/FlashVP/swf files here and unzip into your tables folder.

http://www.hyperspin-themes.com/downloads/HyperPin/Monopoly_FVP_BBB_v2_PDmod.zip

STEP 3: Run the table, if you dont have the correct rom files then try these:

http://www.hyperspin-themes.com/downloads/HyperPin/monopoly.zip

Optional:

If you are a HyperPin user then you can download the media pack here:

Unzip this into your HyperPin installation directory and it will fill in your media files for you.

http://www.hyperspin-themes.com/downloads/HyperPin/Monopoly (Stern 2001).zip

Then add this to your Visual Pinball database:

<game name="Monopoly_FVP_BBB_v2_PDmod">

<description>Monopoly (Stern 2001)</description>

<manufacturer>Stern</manufacturer>

<year>2001</year>

<type>SS</type>

</game>

***THIS IS JUST A TEST TABLE****

The FVP included with this package only works with this table and is not ready for others to use yet to make tables. This is because depending on how this table runs on a majority of the users computers will help me determine if I should continue with this project or move on to one of my many other projects. This table might require a beefy pc and FVP is just merely an experimental idea that I thought might be cool to make. So if it doesnt work for you then you can let us know and provide feedback. But crying about it probably wont make it run faster. Thanks!

Edited by BadBoyBill

Share this post


Link to post
Share on other sites

WOW JUST WOW! What more can I say!! This table alone makes me want a cab. I cant have one yet but one day... One day. Awesome work, FlashVP is a very nice add-on indeed.

Share this post


Link to post
Share on other sites

Looks awesome! I think you're definitely correct about the need for a beefy PC.

I'm running:

EVGA GeForce GTX 260

3 GB RAM,

but with an old Pentium 4 3GHz Processor.

It's basically unplayable and the CPU is running at about 96% steady.

Time for me to upgrade the CPU!

Share this post


Link to post
Share on other sites

Naice 3B and team!! Congrats on getting this table out!! Looks brilliant, cant wait to play it!!

Thanks guys

Timbo

Share this post


Link to post
Share on other sites

This table is amazing. It is a work of art. But you definitely need a better PC than I am running. I have a 3.1 GHz P4 with 3 GB Ram and a 9800GT and I get a very noticeable delay when hitting the flippers.

Share this post


Link to post
Share on other sites

Thanks for all of your hard work. FVP is going to be an amazing addition to VP.

I have not yet tested it on my cab, but I did just do a test run on a fairly high end gaming pc..

i7 920 processor

12 gb Ram

Nvidia 280GTX

Vista 64bit

It looks like it is running a solid 60fps for the most part, but will slow down a bit when alot is happening on screen. There is no flipper delay. Do you guys know how to check FPS while playing?

I'll test it on my cab pc in the morning and let you know.. Q6600, 4gb ram, Nvidia 8800gt.

Thanks again.

Share this post


Link to post
Share on other sites
Guest rossicomputers

Hi BBB,

Tried to run Monopoly is getting error:

line 38 FVp.Connect "127.0.0.1", 50000

Could not connect...

line 54 socket is not connected

How to fix this???

Edited by rossicomputers

Share this post


Link to post
Share on other sites

JUst Curious,

Bill what are specs on your computer you are running HP with and graphics card?

I'll try it out tomorrow after work as I'm heading for bed.

Share this post


Link to post
Share on other sites

e8400, 9800gtx 512, 2GB ram. This table works pretty good for me, I get slight ball stutter during multiball. When I turn off the Fading light system the table works alot better, so I wonder if theres a better way to optimize that system. It seems to run code to update the lights regardless of the light state. So if a light is already on and it still tells it to turn on anyways every 40 millisecods. I noticed this when debugging the data sent to FVP. I might have a look at it later.

But I figured it might be hard to run this for most people, so I might return to work on updating HyperSpin since it desperately needs an update. We'll see what others say. But you guys can try turning the flashers off and make a comparison. In the script at the top maybe 10 or 15 lines from the top is a seting to turn the flashers to false.

Share this post


Link to post
Share on other sites
Hi BBB,

Tried to run Monopoly is getting error:

line 38 FVp.Connect "127.0.0.1", 50000

Could not connect...

line 54 socket is not connected

How to fix this???

Did you get all the necessary files and install the baseline installer?

Try exiting vp and restarting then try the table again, make sure FVP is not running already in the task manager first or you will get this error.

Lastly if all else fails, you can try setting the FVP timer to a higher number, maybe from 3000 to 4000. In the editor look at the timer objects on the right side of the table and find one called FVP timer and click on it and set the time to a higher time.

Share this post


Link to post
Share on other sites
Guest rossicomputers
Did you get all the necessary files and install the baseline installer?

Try exiting vp and restarting then try the table again, make sure FVP is not running already in the task manager first or you will get this error.

Lastly if all else fails, you can try setting the FVP timer to a higher number, maybe from 3000 to 4000. In the editor look at the timer objects on the right side of the table and find one called FVP timer and click on it and set the time to a higher time.

Changed hte FVP Timer to 4000 and DO NOT WORK!!

Works once and the error get it back

Edited by rossicomputers

Share this post


Link to post
Share on other sites
Guest rossicomputers

All graphics chop and slow motion ball.....

Never get this kind error before... All tables runs fine except MONOPOLY!!!!!

Have new dell Machine:

3.0 Duo core 2 Intel

1 GB Gforce GTS 250

300 GB Hardrive

6 GB RAM memory

What else????

Edited by rossicomputers

Share this post


Link to post
Share on other sites
Guest rossicomputers

Changed the FVP Timer to 6000 and WORKS!!

But the table runs chop and slow... table ball in slow motion!!!

What can i DO???????

Help!!!!!!!

Share this post


Link to post
Share on other sites
Guest rossicomputers
Whats your cpu percent running at, open the task manager while you play the table.

6%

Share this post


Link to post
Share on other sites

Its only 6 percent cpu and its choppy during normal gameplay? Some people have had choppy ball issues with other tables not because of the cpu but because of the newer Nvidia drivers, Ive heard the older 182 drivers fix that issue. Im actually going to roll back tonight I thing to see if it helps any.

Share this post


Link to post
Share on other sites
Guest rossicomputers
Its only 6 percent cpu and its choppy during normal gameplay? Some people have had choppy ball issues with other tables not because of the cpu but because of the newer Nvidia drivers, Ive heard the older 182 drivers fix that issue. Im actually going to roll back tonight I thing to see if it helps any.

Tried to run in 2 diferents computer....

Not sucess...

Chop graphics.....

Share this post


Link to post
Share on other sites
Guest rossicomputers

Change graphics dirvers for 182 .NOT sucess...

I Have 348 tables in my pincab... Only Monopoly does want to run.... Why????

I WANNA MY MONOPOLY TABLE...

I WANNA MY MTV....

Buaaaaaa ..... Buaaaaaaaaaa ..... Buaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa....

Share this post


Link to post
Share on other sites

BBB .. fantastic work .. but unfortunately I have to upgrade my card (know issue ;) ) ..

Nevertheless - thanks for all the effort on this beautiful looking recreation for which you'll give us hours of fun (after upgrading my system .. ;) )

Cheers,

FD.

Share this post


Link to post
Share on other sites

I have a GTX 280, 8GB of RAM and a QuadCore running at 3.0GHZ and can't run the table without slowdown. That's why Bill stated it's a test table to gauge peoples performance. So there isn't anything you can really do. Turning off the flashers in the script does help slightly.

Change graphics dirvers for 182 .NOT sucess...

I Have 348 tables in my pincab... Only Monopoly does want to run.... Why????

I WANNA MY MONOPOLY TABLE...

I WANNA MY MTV....

Buaaaaaa ..... Buaaaaaaaaaa ..... Buaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa....

Edited by kingb33

Share this post


Link to post
Share on other sites

well BBB i ran this on my MAME machine just to see how it would handle it.

Intel Celeron Dual Core E1200 Processor - 1.60GHz, 512KB Cache, 800MHz FSB

2GB PC5400 DDR2 667MHz Memory

XFX MG-61Mi-7059 Motherboard - nForce 610i/7050, Socket 775

WD Caviar 160GB Serial ATA HD 7200/8MB/SATA 3G

GeForce 8500 GT Video Card - 1GB DDR2, PCI Express

--------------------------------------------------------------------------------------

as you can see my pc isn't that beefy... far from it. it's running XP and seems to handle this table fairly well... i can't give you a framerate, but it's probably a little under 30fps. i can tell that if i got multiball going, it would start to slow down drastically.

that said, if i had a better system it would probably run just fine. good thing i haven't got started on my cab. now i have a better idea of what i'll want to put in it.

Share this post


Link to post
Share on other sites

Hi,

I'll start by saying this is the most visually impressive table I've ever seen.

unfortunately I can't get it to run using the supplied config.

I've been running all the other tables without any problems.

I've installed everything per the instructions.

I can't get the rom (3.20) to load.

When I check the rom with pinmame all crcs are good and the status is OK. When I try a pinmame rom test I get the following error message "machine terminated before initialized, check the rom path or rom file"

I checked the paths - they are all correct - and the files are in the correct directory.

I redownload the rom from ipdb, - placed the files in the rom directory - still get the same error.

I reinstalled pinmame 2.1 - uninstalled it - (including deleting the registry entries) - installed it over the top of the old install and tried it again - still get the error message.

I tested the monopoly 3.03 rom - works just fine. I modified the monopoly script to use it and the table loads.

I've got a quad core 2.4ghz, geforce 8800gtx (768mb), 2Gb ram and Vista. (UAE is disabled).

with the 3.03 rom the table runs extremely slowly with ball trails.

Anyone else have this problem with the rom? or know how to fix it?

the table looks fantastic Bill - the hyperpin team has raised the bar yet again for table releases - well done

I'm looking forward to playing it when I sort out my configuration issues.

thanks

from Michael

Edited by mike1

Share this post


Link to post
Share on other sites

Hi. I play the table and it's fantastic. But its unplayable on my machine. I have an Intel Dual Core 2.3 Mhz with Gforce 9500GT 1Gb and I play with slow motion :).

But it's a great work!!!!

Share this post


Link to post
Share on other sites

I had the same problem as everyone else with stuttering, slow motion, etc.

I deleted my monopoly.cfg and monopoly.nv and changed the YieldTime value to 0 and I can play the game at full speed now!

Const YieldTime = 0

I have a dual-core 2.5ghz with Gforce 9800 1GB video

Hope this helps someone

Share this post


Link to post
Share on other sites

great to see the table is out.. thanks BBB, it looks brilliant. Unfortunately cant even start it up here due to "cannot create offscreen surface" errors and crashes me out of the program.

Tried reducing my res, even as low as 640x480 as that fixes the issue with other tables with same problem but still same error. Then I turned off hardware rendering and the table loaded and was missing textures everywhere.

Strangely, I then turned the hardware render back on and it loaded, but lots of things were white (ramps, ball was a white square etc). Running very slow.

Only a 256mb 7600GT card here. 3000+ AMD Athlon 64, 1GB ram, XP. So an older machine.

I suspect that I could probably get it running if I reduced all the main playfied textures to 512x1024 as they are currently twice that size. Might give that a try.

Edit: Just reduced all the 1024x2048 textures to half that and table loads ok now. But slideshow gameplay and CPU usage fairly much maxed. Somewhat more playable at 640x480 but still not something I would want to do on this machine.

Thanks again though and I hope you will continue with the project, PC's are only going to get faster and I might even update my own someday.. haha. Xbox 360 has kind of stifled my PC upgrades for a few years.

Edited by Gravytrain

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...