Jump to content
Sign in to follow this  
H4CK3R

Real DMD's In Pinball Cabs

Recommended Posts

deffo get the dmd tested in a real pinball so we can confirm its a firmware thing on the pinDMD :)

Could the 12v plasma be run off a real machine? ? I thought they used different voltages to run.

Sent from my Samsung Galaxy Note II.

Share this post


Link to post
Share on other sites

you would need to bring a 12v psu or find a 12v rail in the machine it self to power the display, the dmd data connector can be plugged straight into the dmd from the machine though :)

Share this post


Link to post
Share on other sites

I tested the plasma today on a real pinball (black rose). It worked perfectly...

Share this post


Link to post
Share on other sites

deffo firmware then, strange how it works on some peoples and not others, must be a tolerance thing hehe. iv made a little test version for you with the latch signal slowed down. i think this might be the problem as its very fast at the moment. if this does not work there is one other area i can look at :)

Share this post


Link to post
Share on other sites

OK...I will try to get a replacement...

But what I want to know is does anyone has a APD128G0320A-1 which works with the pinDMD2?

Share this post


Link to post
Share on other sites

thewool over at vpforums runs the same display, some pictures here

http://www.vpforums.org/index.php?showtopic=21194&page=13

no idea why it works for him and not for you :( (works on my 192x64 plasma fine)

if after you replace the display its the same problem, it must be a timing thing in the firmware and these displays are very sensitive to it so some times get away with it and other times you don't.

Share this post


Link to post
Share on other sites

Is there any reason people use these LED DMDs rather than the plasma ones found in the 90s cabs? Seems to me it'd be a whole lot cheaper to use one of those.

Share this post


Link to post
Share on other sites
Is there any reason people use these LED DMDs rather than the plasma ones found in the 90s cabs? Seems to me it'd be a whole lot cheaper to use one of those.

Ofcourse people would rather use cheap plasma displays. Powering them is the issue though: check their datasheets, they need all sorts of crazy voltages. There are 12v plasma displays out there (vishay with on board power supply), but they cost about 350 pounds.

Share this post


Link to post
Share on other sites

there is some progress in powering the plasma displays over at vpforums :) i think soon we will be able to do it!!! and im first in queue to use that tech haha :)

Share this post


Link to post
Share on other sites

That's great news! I suppose it's more a case of the PSU for the unit being hard to find rather than the logic levels? I've no idea so just speculating.

Share this post


Link to post
Share on other sites

spot the difference time:

now that my vishay has finally turned up from Virtuapin i can show you the difference between the LEE-128G032B-1 and LEE-128G032-1 models

LEE-128G032-1

Share this post


Link to post
Share on other sites



LEE-128G032B-1

there is a slight colour difference the "-1" version is more towards the red spectrum of orange, whereas the "B-1" is the amber version
I actually prefer the B1 (even with the grids), as the colour shades just seem more pronounced. the "-1" version just seems to be lighter and darker LED intensity, whereas the "B-1" is actual colour shades.

also take note the 'B-1" is half the price of the "1"

Share this post


Link to post
Share on other sites

one thing i noticed with the matrix vs single led is on the matrix the pixels are larger so the image seams a little bit clearer as they are not spaced apart so much, but im always lookin at it from like a foot away lol im sure the single led version looks ok from a few foot like you would view in a cab.

Edited by russdx

Share this post


Link to post
Share on other sites

Great videos Mike. It's funny but I kinda prefer the overall appearance of the matrix version. Maybe because the LED's are round vs rectangular or maybe because of the color and shading. The only issue I have with the whole matrix method is the alignment. I know I may be the only one who prefers it but it just seems a little sterile and a little more alive. Call me crazy.

EDIT: just read your write up LOL, guess you like it as well. I know my 8x8 X-Pin is just spectacular, I just can't wait to play video modes now.

Edited by jasonsmith

Share this post


Link to post
Share on other sites
deffo firmware then, strange how it works on some peoples and not others, must be a tolerance thing hehe. iv made a little test version for you with the latch signal slowed down. i think this might be the problem as its very fast at the moment. if this does not work there is one other area i can look at :)

Russ,

Sorry to say but I've got the same problem.

Just hooked the pindmd2 on my plasma display today. and I also have a flickering top line and some dots that should be on top are on the bottom line.

Do you have some alternative firmware for me also?

post-64174-142870588227_thumb.jpg

post-64174-142870588214_thumb.jpg

post-64174-142870588224_thumb.jpg

Share this post


Link to post
Share on other sites

is this the 12v vishay plasma display?

been having alot of problems with this, it works for some people but does not work for others, some other people and now running normal high voltage plasmas ok without problems, so it seams to be this 12v vishay which seams to not work for some people.

iv gone over the firmware many times and cant see any problems with the timing. I cant really solve the problem without having a dodgy unit in front of me to play with, i have the exact same display at the moment but the 192x64 version and it works great.

Would you be willing to ship the display to me so i can have a play see whats up? We can insure it for £500 and package it very well.

Let me know :)

Share this post


Link to post
Share on other sites

Hello Russell,

Yes this is the 12 vishay plasma display.

I'm willing to ship it to you together with the pindmd2, pindmd2 ribbon, usb cable and the 12v powercord I made (molex pc).

I was looking on your site and found other firmware. I read the manual how to change firmware.

One thing I don't understand is step 3 (install the STM DFU USB drivers). Where can I find those?

Best regards Ton.

P.s.

And if I change firmware, what version could I best use? (the latest rev584-16)?

2e p.s.

I managed to update firmware to rev584, but the problem still is there.

pm me your address please.

Edited by Ton

Share this post


Link to post
Share on other sites

Hello

Cool thanks for helping out :), hopefully I can now track down the problem and tweak the firmware accordingly :) Ill pm you my Address, let me know how much the shipping is and ill cover it :)

Share this post


Link to post
Share on other sites

can anyone with a LEE-128G032-1 take a picture of the u23 chip on the back. I sent my dmd off to vishay in January for a rma and just got it back yesterday and its doing the same thing. After inspecting the board in looks as though a couple of pins are bridged and i wanted to compare to someone else's.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...