Jump to content
Fromlostdays

How To Set Up HyperSpin on the Nvidia Shield (Beginners Guide)

Recommended Posts

Hi badhemi,

I just see in your hyperspin setting that you use for amstrad cpc the Caprice32 core but can't find it in retroarch.

Where did you find it.

Thanks.

it was an old retroarch apk

Share this post


Link to post
Share on other sites

So, i can't use it with the lasted version of retroarch ?

You can't download the core. I expect you could give it a shot if you can get the core.

Badhemi, do you have access to your cores to extract them?

RetroArch cores are only held for a short time on the buildbot.

Share this post


Link to post
Share on other sites

hi guys, sorry fo my english .i have shield with dd ext , my hyperspin  is on the dd ext.

i dont  know wha write on  my ini , always error "" miissing rom"

on my dd ext  /Hyperspin/Emulators/Super Nintendo Entertainment System/roms/

if i look with ES he name  my dd ext  USB3007 when open /3007/UsbStorage/Hyperspin/Emulators/...

and  when  i look for my roms with retroarch /storage/2894CDEA94CDBB18/Hyperspin/Emulators/...

what i must  write in  my ini for rompath please ?  

exe info]
path=\hyperspin\emulators\Super Nintendo Entertainment System\
rompath=/storage/Hyperspin/Emulators/Super Nintendo Entertainment System/roms/
 
thanks for anwers

Share this post


Link to post
Share on other sites

You can't download the core. I expect you could give it a shot if you can get the core.

Badhemi, do you have access to your cores to extract them?

RetroArch cores are only held for a short time on the buildbot.

no sorry. I'm mad about losing it

Share this post


Link to post
Share on other sites

You can't download the core. I expect you could give it a shot if you can get the core.

Badhemi, do you have access to your cores to extract them?

RetroArch cores are only held for a short time on the buildbot.

no sorry. I'm mad about losing it

Share this post


Link to post
Share on other sites

 

hi guys, sorry fo my english .i have shield with dd ext , my hyperspin  is on the dd ext.

i dont  know wha write on  my ini , always error "" miissing rom"

on my dd ext  /Hyperspin/Emulators/Super Nintendo Entertainment System/roms/

if i look with ES he name  my dd ext  USB3007 when open /3007/UsbStorage/Hyperspin/Emulators/...

and  when  i look for my roms with retroarch /storage/2894CDEA94CDBB18/Hyperspin/Emulators/...

what i must  write in  my ini for rompath please ?  

exe info]
path=\hyperspin\emulators\Super Nintendo Entertainment System\
rompath=/storage/Hyperspin/Emulators/Super Nintendo Entertainment System/roms/
 
thanks for anwers

 

I believe your path should be  

 

/storage/2894CDEA94CDBB18/Hyperspin/Emulators

Share this post


Link to post
Share on other sites

Can someone please help. I got lost at step 7, wat are roms and where do I find these? I got my self a Nvidia Shield didnt know I had to install al those things my self gggrrrr and there is no tutorials in Dutch so its very hard for me

 

greetings from the Netherlands

Share this post


Link to post
Share on other sites

Roms=games

We can't really tell you where to get them as downloaded roms is a legal grey area.

Share this post


Link to post
Share on other sites

Can someone please help. I got lost at step 7, wat are roms and where do I find these? I got my self a Nvidia Shield didnt know I had to install al those things my self gggrrrr and there is no tutorials in Dutch so its very hard for me

 

greetings from the Netherlands

I understand now that roms are the game it self pff feel so stupid. So I used this tutorial and put everything on a usb stick and now hyperspin does start up jippieeeee but now it says ettempting launch missing rom. Is the something wrong with the roms do I have to do something with them?

Share this post


Link to post
Share on other sites

Missing rom error is common, there should be plenty of comments in this forum, try a search of the error message.

Briefly.

1. Your ROM names must exactly match the gamenames in the XML database file. (Located in databases folder under the name of your system)

2. The file extensions of your ROM files must be entered correctly in your settings file for that system(.ini file) seperated by comma. (Cue,bin,zip,7z etc..)

Zip file roms are not compatible with everything though. I keep most things unzipped whee I can

3. The biggest trip up is the rompath= entry in your settings ini for the specific system.

You need to make sure that is all correct to the location of you roms. (Hard to know what yours is) again there is plenty on here about that. Check the recent thread about Running Hyperspin from NAS drive.

Don't feel stupid man I was in the same boat not so long ago!

Share this post


Link to post
Share on other sites

Yes did it, I can see all the games in Retroarch now, is it normal I have to play them in Retroarch before I can play them in Hyperspin? And I have 2 isue's now, in my screen wen I play there is a print of a joystick, is this normal or can I take it away some how? And second isue is that when I click on run to play a game in retroarch it ask me what the core is that I want to use, if I click on the wrong one the game wont work. Its gonna take a long time to go true all the options for all the games so I guess I do something wrong?

 

Thanks for all the help 

Share this post


Link to post
Share on other sites

FYI you can add a filter in the settings ini for each emulator to only show roms you have. After setting this, if you don't see roms you know you have then you will know they aren't named correctly. Also Android is far more sensitive with naming than windows. So even if it shows up in Windows it may not on Android. For example... sonic and knuckles. It uses "&" on all standard hyperlist databases and Android will not read it. Had to change media, database, and Tom name to get it showing up.

But yea you absolutely don't need to launch each game in retroarch first. Heck you don't even need to add or scan the directories.

Share this post


Link to post
Share on other sites

I have a nvidia sheild tv that i'm trying to use my working windows setup I have added the files to my setup but I cant get the roms to load. I have hyperspin starting up fine the game videos will play and i can get to the point to select the roms fine After looking at my windows set up I think the path to the rom is setup a little different then a stock windows set up. I have tried to change the path in the android setup to match the windows but no luck yet. Here is the path to my windows setup to the roms.D:\Arcade\Nintendo Entertainment System\roms.

Would it be better to change the windows set or change the android set up to get everything to work on both setups. Also what files need to be changed Thanks

Share this post


Link to post
Share on other sites

You need to create a 2nd set of settings files specifically for android.

 

To combine this with your windows setup add a folder to your Hyperspin folder called Settings_Android

 

See Here for more detail

 

Place all your settings files in there and adjust your rom path to match where your roms are stored on your Shield, USB, external drive or networked drive.

 

BTW where are your android roms stored?

Share this post


Link to post
Share on other sites

I don't have a great deal of experience outside of my own setup. Is this one you have built yourself or accuired?

I'm assuming you are plugging this drive directly into your shield? (Strange because I thought Hyperspin android would only find a Hyperspin folder but yours is called Arcade! Anyway you say it's working)

I think your rompath should have / instread of \

Try changing one of your Settings_Android ini's to match

Like this

Arcade/Nintendo Entertainment System/roms

Just focus on one system make sure your roms for Nes are not zipped. Should be .nes

Also I have seen full rompaths used with external drives(I don't use one)

Look in Es file explorer for the ID of your drive your rompath will be something like this if so

Storage/hsbdboajbev8263617/Arcade/Nintendo Entertainment System/roms

Please report back its good to know what does and doesn't work.

Share this post


Link to post
Share on other sites

how does the path start off when using a ext hdd on the sheild?  /storage/sdcard0/?   /storage/usb/? or something

Share this post


Link to post
Share on other sites

If it can see your roms within your Hyperspin folder then should Have no start. Just the 1st folder that's in Hyperspin folder. (No dots, no slashes)

In your case

Nintendo Entertainment System/roms

After that use Es file explorer to look in you shield folders for the Storage folder

In there will be your storage folders.

Or if you have retroarch installed I used it to browse to my roms and it displayed the full path to my roms as it went.

I have a shield pro and roms are on the internal drive.

My path is

Storage/emulated/0/ROMs/Nintendo Entertainment System

I have not tested any others but as I say yours may come up with a long ID number. Have a browse through the forum again there are plenty of real life examples in the threads. Probably this thread also

Share this post


Link to post
Share on other sites

Just done a tutorial which may give you another resource to reference. In the signature.

Check the posts in there as there is a big set of settings files

Share this post


Link to post
Share on other sites

what else would make it say Attempting launch missing rom... I am using a fresh setup and have rechecked rom path many times using retro and es file exploreer

Share this post


Link to post
Share on other sites

what else would make it say Attempting launch missing rom... I am using a fresh setup and have rechecked rom path many times using retro and es file exploreer

not spelled correctly in xml file

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...