Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Announcement

    Sorry for the recent downtime. Still much to do but we have the site updated, secure and back online.  Expect more changes.

HyperSpin 1.5.1 Public Release


fr0stbyt3

Recommended Posts

  • 1 month later...
2 minutes ago, richie_jones said:
6 hours ago, joe35car said:
Ok I just upgraded to the newest HS and I have no idea how to get the wheels to animate.
 
Thanks

Was it as painless as just changing the exe. I'm tempted but have put 100's of hours in getting setup right. Not sure if it's worth the risk...

Yup you just replace the exe files. So far no problem. I guess I have to convert my wheel png to swf format for them to work? Any thing else I need or a program? 

  • Like 1
Link to comment
Share on other sites

Yup you just replace the exe files. So far no problem. I guess I have to convert my wheel png to swf format for them to work? Any thing else I need or a program? 
I think the wheel png files should work but if there is a swf animation in same folder with same name that will take presidence...
Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

great fun here, hadn't turned on my cab for a few months and it was dead when I did over the weekend (must have been hit with a surge and blew the hdd, or else it was just a crappy drive). reinstalled now on windows 10 1809 and looks like im part of the crew who cant get it working at all!

any pointers on where I should start? or is it best to just roll back to a known working version of OS?

Link to comment
Share on other sites

  • 2 months later...
On 5/12/2018 at 6:20 AM, Aorin said:

Yeah, people should move on, there are other alternatives.

TonesMalone, this is not directly to you, it's just some words I often think of when I read people complaining about some stuff and it's not even directly only for Hyperspin.

There's a misconception of the word "old" in general, stating "old" as bad or useless is a general way of thinking.

Even technology, which is a field that gets "old" so fast, like, say, computers still relies on old stuff, just because they were great ideas to begin with.

Do you have a replacement on par with your old mouse or keyboard? Touch won't do. Decades come and go, and probably they will still be kicking in the next decades to come. I bet people still complains they don't like mice or keyboards, because they just want to complain about something. Satisfaction may be hard to achieve at times. So just move on to what can possibly do it for you. I often read people that aren't even satisfied with the new choices, so the problem is so close it can hardly be seen.

It seems that we're addicted to constant updating , yet we still play old games and find they amazing, again because they were great ideas and fun is fun, on 1920 or 2020. A lot of things break when constant updating happens, one of them is my patience. People are too much anxious and anxiety is not a good thing, blame it on constant updates.

@Aorin I can't agree with you more. Love love love your content BTW.

@tonesmaloneFunny, if i have an issue with how something works, i don't complain. I learn and try my hand at fixing it. Everyone complaining about when hs 2.0 is getting released, are a bi-product of the society we live in. the society of instant gratification. Unwilling to work for what they want.....nothing but cry baby pussies. If they want to leave, fuck em, let em... we don't need that toxicity. This is a great community of TRUE retro gamers. A generation of gamers that lived the slower, lifestyle. We walked to the pizza place to play mortal kombat, so we can appreciate the time it takes for greatness. Then we got older and watched everything change and the crybaby generation come into the world with the fast paced, instantly served on demand, always updating. "don't gotta go anywhere" cause its all here and if its not, 'i will cry until i get it'

Edited by ctindell1981
Spelling correction
  • Like 2
  • Super Like 1
Link to comment
Share on other sites

  • 3 months later...
On 5/8/2018 at 10:14 AM, malarrya said:

Hey guys, thanks for all the great work. I do have one issue, though. This update kinda messed up the wheel positioning for my Dungeons & Dragons theme. I tried to re-position the wheel images but the images are skewed to the right and the middle image is way off center and sits closer to the right-hand images. When I first looked at it, the images were way out of whack.

BEFORE: (This is a much more desirable look for a horizontal wheel)D&D_before.png.af1be6602d0472c6c4fc878213de95cc.png

AFTER (The center image starts from the same top position as the small images and skewed to the right - this doesn't look correct)

D&D_after.png.c54cbb2e06c4b6a5dbd54aa1a0d2ff06.png

I'm having the same problem with the 1.51 update. This only happens with horizontal scrolling + centered wheels. But what I do that's unique is have only 1 system show at a time. So you scroll through the system menu left <> right, and the previous and next systems would normally appear but I have those wheels set to 1 px in HyperHQ so they don't show up, giving me a display of 1 system at a time rather than 5. If this is fixed that would be awesome since it's the only thing preventing me from updating from 1.4. I'd love to take advantage of the bug fix of HS filling only half the screen immediately after exiting a game.

Link to comment
Share on other sites

  • 2 weeks later...

SO I just want to let you guys know that Hyperspin and Hyperhq are non functional again in the latest windows 10 insider preview. i have confirmed it with two separate independent hyperspin installs. This is likely going to be an issue once the next major windows feature update rolls out so hyperspin likely needs a update along the same lines of what was done previously to get its dependencys updated. just FYI.

  • Like 1
Link to comment
Share on other sites

26 minutes ago, cid67 said:

SO I just want to let you guys know that Hyperspin and Hyperhq are non functional again in the latest windows 10 insider preview. i have confirmed it with two separate independent hyperspin installs. This is likely going to be an issue once the next major windows feature update rolls out so hyperspin likely needs a update along the same lines of what was done previously to get its dependencys updated. just FYI.

Thanks for the heads up. Did you grab a clean install from the forums or did you copy an install that worked previously?

Link to comment
Share on other sites

I have a fully functional hyperspin setup on a external drive that i keep as a backup in case something goes wrong with my main hyperspin setup that is also on a separate external hard drive that is different form the other one. Both fail to launch. hyperspin and hyperhq are not operational. hyperspin also fails to report anything in its log. rocketlauncher backend still functions normally i will add though thats largely irrelevant.

  • Like 2
Link to comment
Share on other sites

On 2/7/2020 at 12:02 AM, fr0stbyt3 said:

Thanks for the heads up. Did you grab a clean install from the forums or did you copy an install that worked previously?

If there is an issue maybe worth putting a Notice on Hyperspin forum like the last one from a year or so ago ?

This would avoid many people from accidently updating and then having a non functioning setup. Just a thought ?

Link to comment
Share on other sites

Here is a hyperspin crash report from the windows event viewer in case it helps. it appears the crash is in some way related to ntdll.dll best i can tell.
 
- <System>
  <Provider Name="Windows Error Reporting" />
  <EventID Qualifiers="0">1001</EventID>
  <Version>0</Version>
  <Level>4</Level>
  <Task>0</Task>
  <Opcode>0</Opcode>
  <Keywords>0x80000000000000</Keywords>
  <TimeCreated SystemTime="2020-02-08T17:42:43.8673381Z" />
  <EventRecordID>480</EventRecordID>
  <Correlation />
  <Execution ProcessID="0" ThreadID="0" />
  <Channel>Application</Channel>
  <Computer>DESKTOP-FRJU4SE</Computer>
  <Security />
  </System>
- <EventData>
  <Data>2256276966129668927</Data>
  <Data>1</Data>
  <Data>APPCRASH</Data>
  <Data>Not available</Data>
  <Data>0</Data>
  <Data>HyperSpin.exe</Data>
  <Data>1.5.1.0</Data>
  <Data>5aec9b23</Data>
  <Data>ntdll.dll</Data>
  <Data>10.0.19559.1000</Data>
  <Data>3188ed05</Data>
  <Data>c0000005</Data>
  <Data>0008fee4</Data>
  <Data />
  <Data />
  <Data>\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER6DF0.tmp.mdmp \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER6E2F.tmp.WERInternalMetadata.xml \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER6E40.tmp.xml WPR_initiated_DiagTrackMiniLogger_OneTrace User Logger 20200130 1 Event Collector_0_inject.etl \\?\C:\Users\mike_\AppData\Local\Temp\WER6F0C.tmp.etl WPR_initiated_DiagTrackMiniLogger_WPR System Collector_inject.etl \\?\C:\Users\mike_\AppData\Local\Temp\WER6F0D.tmp.etl \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER6F0B.tmp.csv \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER6F2B.tmp.txt</Data>
  <Data>\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_HyperSpin.exe_2171fe5c76183129e6394446347a12b29295d2d3_1556631f_c486d9dd-3c7f-462c-be84-724ada1dc2ba</Data>
  <Data />
  <Data>0</Data>
  <Data>372214fb-ee0c-45df-a05a-1cf2d02a0995</Data>
  <Data>268435456</Data>
  <Data>855871f4865a27d98f4fe7f2490e133f</Data>
  <Data>0</Data>
  </EventData>
  </Event>
Link to comment
Share on other sites

On 2/7/2020 at 9:07 AM, cid67 said:

I have a fully functional hyperspin setup on a external drive that i keep as a backup in case something goes wrong with my main hyperspin setup that is also on a separate external hard drive that is different form the other one. Both fail to launch. hyperspin and hyperhq are not operational. hyperspin also fails to report anything in its log. rocketlauncher backend still functions normally i will add though thats largely irrelevant.

If you could, please download a fresh copy of HS 1.5.1 and run it. In order for me to test and patch this, I need a common, reproducible test case.

7 hours ago, Creezz67 said:

If there is an issue maybe worth putting a Notice on Hyperspin forum like the last one from a year or so ago ?

This would avoid many people from accidently updating and then having a non functioning setup. Just a thought ?

We normally don't put out a notice until we're able to verify there is an issue. As with most things microsoft, you shouldn't run to update windows versions the moment it comes out. The last few releases have either been pulled or have caused performance related issues. When we verify that is an issue with an RC we will make a post related to it.

Link to comment
Share on other sites

On 1/24/2020 at 9:22 PM, Ayrun said:

I'm having the same problem with the 1.51 update. This only happens with horizontal scrolling + centered wheels. But what I do that's unique is have only 1 system show at a time. So you scroll through the system menu left <> right, and the previous and next systems would normally appear but I have those wheels set to 1 px in HyperHQ so they don't show up, giving me a display of 1 system at a time rather than 5. If this is fixed that would be awesome since it's the only thing preventing me from updating from 1.4. I'd love to take advantage of the bug fix of HS filling only half the screen immediately after exiting a game.

The code for positioning wasn't altered between builds. So I find this quite odd. Can you link me to the theme so I can test locally?

Link to comment
Share on other sites

Quote

If you could, please download a fresh copy of HS 1.5.1 and run it. In order for me to test and patch this, I need a common, reproducible test case.

I did that earlier today. I downloaded the full 1.51 package and tried executing both hyperhq and hyperspin and both failed to launch.

Quote

As with most things microsoft, you shouldn't run to update windows versions the moment it comes out. The last few releases have either been pulled or have caused performance related issues

II am fully aware of this fact and am prepared  for the consequences of running pre release software. Im just hoping we can get this straitened out before  it hits all users. of coarse i would love to get a fix that prevents me from having to reinstall windows but that's obviously up to hyperspin dev team discretionf order for 

Link to comment
Share on other sites

8 minutes ago, cid67 said:

I did that earlier today. I downloaded the full 1.51 package and tried executing both hyperhq and hyperspin and both failed to launch.

II am fully aware of this fact and am prepared  for the consequences of running pre release software. Im just hoping we can get this straitened out before  it hits all users. of coarse i would love to get a fix that prevents me from having to reinstall windows but that's obviously up to hyperspin dev team discretionf order for 

We obviously do not want our users reinstalling windows as a fix. I can't update my main PC to a beta release of windows, but i'll spin up a VM to see if I can reproduce later in the week.

Please understand this process could be a week or two as i'm dealing with a recent death in the family.

Please share any additional log files you may have in PMs if you don't want to share them directly here. Also please include the exact version of windows you're running. The insider previews are not always the same version as they roll out updates to users in batches.

  • Like 1
Link to comment
Share on other sites

Sorry to hear about your family. I'm in no hurry over here. id love to get back to my hyperspin build as it is my passion but in the mean time i got plenty of other things to geek out on. any effort at all is always much appreciated. 

Link to comment
Share on other sites

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...